No RS232 communication with PC

Topics related to the Dataman S4

No RS232 communication with PC

Postby picturevalve » 15 Oct 2012 23:27

Can't get my S4 to communicate with the PC via the Com 2 port.
Have checked Windows settings for the port, and these show as 9600 Baud, 8N1 and no flow control

On the S4 WinDriver v2.17 software prefs, the settings are the same.
I understand that when I switch on the S4 a few times I should be seeing what's displayed on the internal LCD display being shown in the terminal window?
Haven't managed to achieve that thus far, or transfer data.
I had a couple of serial cables in stock, but they didn't work, so bought a new lead from Dataman themselves, but still no comms.

What am I doing wrong?
picturevalve
 
Posts: 1
Joined: 15 Oct 2012 23:12

Re: No RS232 communication with PC

Postby Dataman (Neil Parker) » 16 Oct 2012 08:45

Hello picturevalve,

Have you checked the port settings on the S4 itself? These are accessed through FUNC > SETUP. ENTER progresses through the list of settings and the left right arrow keys modify the values. ESC saves the changes and exits back to the prompt.

As long as the BAUD rates on the S4 driver software and the S4 match, you should have comms. This should be evident through the terminal software echoing the S4 LCD display, as you described.

Please let me know if you continue to have problems and I will try to help further.

Regards,

Neil Parker
Dataman Programmers
Dataman (Neil Parker)
 
Posts: 656
Joined: 10 Nov 2011 09:51


Return to Dataman S4

Who is online

Users browsing this forum: No registered users and 1 guest