ST NAND - ECC Invald Block Management

General topics relating to Dataman that do not fit the above categories
Guest
Posts: 723
Joined: 09 Nov 2011 17:16

ST NAND - ECC Invald Block Management

Postby Guest » 10 Nov 2011 10:35

Hello Guys,

I am struggling with an ST NAND256W3A2BN chip and wondered if anyone out there has had some experience with this. I used the default settings on the first try. I am reading a master chip and trying to program known good, blank, new chip of the same part. I get 958 service multi bit ECC error when we test the board the programmed chip has been placed on. On the second try I changed the settings to Invalid block management - Do not use, Spare area usage to user data and the user area number of blocks from 2008 to 2048. This didn't solve the problem. I still get the same error. Any help would be greatly appreciated. The read and program both complete fine. I know I am doing something wrong somewhere. I am using the 48Pro, software version 2.56.

Egbert

Dataman (Neil Parker)
Posts: 835
Joined: 10 Nov 2011 09:51

Re: ST NAND - ECC Invald Block Management

Postby Dataman (Neil Parker) » 10 Nov 2011 10:36

Hello Egbert,

We have prepared manuals on just this topic which can be found on our website here.

If the answers to your questions are not covered by the manuals then please let me know and I can get the information added, which will also be of use to our other customers.

Regards

Neil Parker


Return to “General Conversation”

Who is online

Users browsing this forum: No registered users and 2 guests