ST GAL20V8S

Topics related to the Dataman 40Pro
andrew96
Posts: 14
Joined: 18 May 2012 22:12

ST GAL20V8S

Postby andrew96 » 19 Feb 2014 00:30

Hi Neil

Trying to read the ST GAL20V8S in my datman 40pro programmer, The chip is in the device list but when i do a read I get the strange error that the chip ID is 20h and the manafactures ID is 20h. To me this matches! but the programmer errors with just that error and wont do a read!

how can I get round the problem?

thanks
Andrew.

L0280: Reading device: STMicroelectronics GAL20V8S.
L0281: Reading device ...
L0282: Manufacturer / device ID check error!
L0283: ID manuf. = 20h, ID device = 20h
L0284: Elapsed time: 0:00:00.9

Dataman (Neil Parker)
Posts: 835
Joined: 10 Nov 2011 09:51

Re: ST GAL20V8S

Postby Dataman (Neil Parker) » 20 Feb 2014 09:05

Hello andrew96,

You can try disabling the "Insertion test and/or ID check" option in the "Device operation options" dialog (Alt+O).

If I can also ask you to recreate the ID error with this device and then generate a problem report using the "Help | Create problem report" feature and emailing the resulting file to support@dataman.com we can look into this error further.

Best regards,

Neil Parker
Dataman Programmer

andrew96
Posts: 14
Joined: 18 May 2012 22:12

Re: ST GAL20V8S

Postby andrew96 » 08 Mar 2014 13:42

Thanks Neil

I have now got back to this board and have discovered they have managed to do some obscure protection on the chips by making the pins 3 and 13 inaccessible when doing a read and getting the device ID, It is not just this one chip, but all the ST GAL20v8S devices on this board and this is a fully working board I wanted to copy the GAL chips to put into a non worker with the gal chips are dead!

No idea how they have managed to do this but it sure seems to work to protect them!!

No doubt no way to overcome this!

regards

Andrew


Return to “Dataman 40Pro”

Who is online

Users browsing this forum: No registered users and 1 guest