Cannot install 40PRO on Win 10 x64

Topics related to the Dataman 40Pro
kcsl_hunts
Posts: 2
Joined: 21 Apr 2020 12:40

Cannot install 40PRO on Win 10 x64

Postby kcsl_hunts » 21 Apr 2020 13:01

I've just received my 40PRO device today but am having problems getting Windows to install the driver.

Followed the Quick Start guide by connecting the programmer to the USB port and it's PSU.
Windows immediately detected the programmer but shows an error "Unknown USB device (device descriptor request failed)."
Tried to tell Windows to use the driver located within the installation folder "C:\Program Files (x86)\Dataman\Dataman-Pro\drivers\usbdrv\W10" but it insists "the best drivers for your device are already installed".

Tried a reboot and a different USB port but no joy.

So moved to a different PC and tried a different approach.
Downloaded and installed the latest software (3.58/04.2020) no problem.
Plugged in the programmer and immediately get the same error message.
This machine is running Windows 10 PRO Version 1903 (OS Build 18362.778)

Any suggestions please ?
Joe

Dataman (Neil Parker)
Posts: 835
Joined: 10 Nov 2011 09:51

Re: Cannot install 40PRO on Win 10 x64

Postby Dataman (Neil Parker) » 21 Apr 2020 16:26

Hello Joe,

Your second method should definitely work. Can you see what the programmer is showing up as under the Windows Device manager? The only reason the USB driver would not have been installed is if it was refused during the software installation process.

Please be sure to select the correct programmer type from the Find programmer dialog:
find programmer.PNG
find programmer.PNG (11.58 KiB) Viewed 697 times

If you continue to have problems then please provide a copy of the problem report showing the error message you are seeing. This can be generated using the (Help > Create problem report) feature in the software.

Best regards,


Neil Parker
Dataman Programmers

kcsl_hunts
Posts: 2
Joined: 21 Apr 2020 12:40

Re: Cannot install 40PRO on Win 10 x64

Postby kcsl_hunts » 25 Apr 2020 19:24

Hi Neil,

So I went back this morning and everything now seems fine.
I'm wondering if there were some Windows updates being downloaded. I had rebooted several times to noavail, but today I plugged the programmer in to attempt to capture the information you requested and everything worked fine.
Read, programmed and verified several EPROMS with no issue.

So all's well that ends well I suppose.
I'll be back in touch if it goes wrong again, but hopefully that's the end of the issue.

Kind regards,
Joe


Return to “Dataman 40Pro”

Who is online

Users browsing this forum: No registered users and 1 guest